Changes between Version 38 and Version 39 of FAQ


Ignore:
Timestamp:
Jun 19, 2010 6:26:14 AM (7 years ago)
Author:
pbaumann
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • FAQ

    v38 v39  
    22
    33= How-To and FAQ =
     4
     5You may want to consult these sources of information as well:
     6   * [wiki:Install How to install]
     7   * [[wiki:CommonQueryProblems Common Query Problems]]
     8
     9== Questions and Answers ==
    410
    511 * '''Q: Using ''automake'' I get an error message "directory should not contain /" - what can I do?'''
     
    5157   A: Division of two integers yields an integer. If you want to have a float result then you need to cast the operands (that is: at least one of them) to float or double.
    5258
     59 * '''Q: Using ''automake'' on petascope I get an error message "directory should not contain /" - what can I do?'''
     60
     61   A: Probably you have an outdated automake version installed, we have seen such problems with 1.7.9. Upgrade to at least 1.10.1.
     62
     63 * '''Q: I get weird error messages from the Java runtime system which seems to hint at class version incompatibilities, such as "Class version error" or "Class not found".'''
     64
     65   A: There might be a conflict with the locally provided libraries, to be found at directory $PETASCOPE/lib. Check them, and if you find a mismatch then remove them and use the resp. libraries of your local installation instead. Alternatively, consider upgrading your Java SDK to version 1.6.
     66
     67 * '''Q: I want to use a different version of PostgreSQL. Is that possible?'''
     68
     69   A: You need to include a different JDBC postgresql driver (as a JAR) in the libraries folder and update the Makefile as needed. Then you can try out another PostgreSQL version, it may or may not work. Let us know your experiences to update this information!