wiki:FAQ

Version 40 (modified by pbaumann, 7 years ago) (diff)

--

How-To and FAQ

You may want to consult these sources of information as well:

Questions and Answers

  • Q: Using automake I get an error message "directory should not contain /" - what can I do?

A: Probably you have an outdated automake version installed, we have seen such problems with 1.7.9. Upgrade to at least 1.10.1.

  • Q: While installing rasdaman I find out, during ./configure, that some further packages are required. Can you give a summary of these?

A: These are summarized on the Download page.

  • Q: Having done all the above, ./configure complains about missing curses although ncurses is there.

A: You have run into a bug in the ncurses package; in /usr/lib, manually create symlinks libcurses.a -> libncurses.a and libcurses.so -> libncurses.so.

  • Q: configure complains that some required files, like install-sh, cannot be found.

A: retry ./configure after running

automake --add-missing
  • Q: I get a link error, function ECPGget_connection cannot be found.

A: What appears to have happened is that in PostgreSQL 8.3.0 they removed ECPGget_connection and they have reintroduced it by 8.3.7. So PostgreSQL versions 8.3.0 up to (but excluding) 8.3.7 cannot be used.

  • Q: I get C++ compilation errors.

A: Make sure you use the proper compiler version (see Requirements?). GNU folks have a relaxed view on backwards compatibility even with minor release changes, and we have experienced such problems indeed.

  • Q: When running the script "create_db.sh", I get the following cryptic error message: Creating base RASBASE...Warning/error in AdminIf? Connect: SQLSTATE: 08001 SQLCODE: -402

A: There are several possible reasons:

Execution permissions. Run the script as the user owning the postgresql processes. Use only that user for further work with rasdaman (see Installation Guide). If you use Ubuntu and installed postgres with apt-get, then you should probably login as user postgres. (The postgres db does not allow full access to rasdaman tools, because they do not run under the administrative user that launched the db server process.)

Blocked incoming connections. Another cause of the problem might be that postgres does not allow incoming connections. If you have Postgres v8 or more recent, modify file "postgresl.conf" and set (uncomment) the option

listen_addresses = 'localhost'

TCP-IP connection. If you have Postgres v7, set (uncomment) the following option:

tcpip_socket = true

  • Q: Aggregation result from select max_cells(c.0) from rgb as c: If I send this query via command line (rasql utility), then the result is 255; if I send this query via RasJ, then the result is -1.

A: Java does not have an 8-bit unsigned data type. Byte is a signed 8 bit and hence 255 is represented as -1. What you can do is to transform bytes to char by adding 28 if the 27 bit is set. Tested, works.

  • Q: When using division "/" as an induced operation I get unexpected results.

A: Division of two integers yields an integer. If you want to have a float result then you need to cast the operands (that is: at least one of them) to float or double.

  • Q: Using automake on petascope I get an error message "directory should not contain /" - what can I do?

A: Probably you have an outdated automake version installed, we have seen such problems with 1.7.9. Upgrade to at least 1.10.1.

  • Q: I get weird error messages from the Java runtime system which seems to hint at class version incompatibilities, such as "Class version error" or "Class not found".

A: There might be a conflict with the locally provided libraries, to be found at directory $PETASCOPE/lib. Check them, and if you find a mismatch then remove them and use the resp. libraries of your local installation instead. Alternatively, consider upgrading your Java SDK to version 1.6.

  • Q: I want to use a different version of PostgreSQL. Is that possible?

A: You need to include a different JDBC postgresql driver (as a JAR) in the libraries folder and update the Makefile as needed. Then you can try out another PostgreSQL version, it may or may not work. Let us know your experiences to update this information!

Attachments (1)

Download all attachments as: .zip